This project has moved. For the latest updates, please go here.
1
Vote

Can not install (required version of .Net-Framework issue)

description

I'm having troubles installing 2.0.1 r7 for Visual Studio 2013. I'm running Visual Studio 2013 Community. The installation fails with "The extension 'ConfigurationSectionDesigner' requires a version of the .NET Framework that is not installed."

Here's the log:
23.09.2015 10:02:05 - Microsoft VSIX Installer
23.09.2015 10:02:05 - -------------------------------------------
23.09.2015 10:02:05 - Initializing Install...
23.09.2015 10:02:05 - Extension Details...
23.09.2015 10:02:05 - Identifier : 9f16956e-2232-4f80-9ebb-4165929ef3ef
23.09.2015 10:02:05 - Name : ConfigurationSectionDesigner
23.09.2015 10:02:05 - Author : The Community
23.09.2015 10:02:05 - Version : 2.0.1.7
23.09.2015 10:02:05 - Description : A Visual Studio add-in that allows you to graphically design .NET Configuration Sections and automatically generates all the required code and a schema definition (XSD) for them.
23.09.2015 10:02:05 - Locale : en-US
23.09.2015 10:02:05 - MoreInfoURL : http://csd.codeplex.com/
23.09.2015 10:02:05 - InstalledByMSI : False
23.09.2015 10:02:05 - SupportedFrameworkVersionRange : [4.5]
23.09.2015 10:02:05 -
23.09.2015 10:02:05 - Supported Products :
23.09.2015 10:02:05 - Microsoft.VisualStudio.Pro
23.09.2015 10:02:05 - Version : [12.0]
23.09.2015 10:02:05 -
23.09.2015 10:02:05 - References :
23.09.2015 10:02:05 -
23.09.2015 10:02:05 - Searching for applicable products...
23.09.2015 10:02:05 - Found installed product - Microsoft Visual Studio Community 2013
23.09.2015 10:02:06 - The extension with ID '9f16956e-2232-4f80-9ebb-4165929ef3ef' is not installed to Microsoft Visual Studio Community 2013.
23.09.2015 10:02:06 - Found installed product - Microsoft Visual Studio 2013 Shell (Integrated)
23.09.2015 10:02:06 - Found installed product - Global Location
23.09.2015 10:02:10 - The following target products have been selected...
23.09.2015 10:02:10 - Microsoft Visual Studio Community 2013
23.09.2015 10:02:10 -
23.09.2015 10:02:10 - Beginning to install extension to Microsoft Visual Studio Community 2013...
23.09.2015 10:02:10 - Install Error : Microsoft.VisualStudio.ExtensionManager.MissingTargetFrameworkException: The extension 'ConfigurationSectionDesigner' requires a version of the .NET Framework that is not installed.
bei Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.CheckForValidDotNetFramework(IExtension extension)
bei Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.CheckForInstallBlockers(InstallableExtensionImpl extension, IInstalledExtensionList modifiedInstalledExtensionsList, Boolean isNestedExtension, Boolean& olderVersionInstalled)
bei Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InstallInternal(InstallableExtensionImpl extension, Boolean perMachine, Boolean isNestedExtension, IDictionary2 extensionsInstalledSoFar, List1 extensionsUninstalledSoFar, IInstalledExtensionList modifiedInstalledExtensionsList, AsyncOperation asyncOp, UInt64 totalBytesToWrite, UInt64& totalBytesWritten)
bei Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.BeginInstall(IInstallableExtension installableExtension, Boolean perMachine, AsyncOperation asyncOp)
bei Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InstallWorker(IInstallableExtension extension, Boolean perMachine, AsyncOperation asyncOp)
As I understand the log, the extension requires .Net 4.5, doesn't it? .Net 4.5 is installed on my machine (Windows 10 Prof.) since it is already included in Visual Studio 2013. Any ideas?

This is urgent because I need to update an existing model in a legacy project.

comments

monomorph wrote Sep 23, 2015 at 10:14 AM

Follow up from myself: Today I installed VS Community 2015 to try the package from Ray1984, see https://csd.codeplex.com/discussions/641721. It installed to both VS 2013 and 2105. But I got an error on opening the model in VS 2013 "The type initializer for 'Microsoft.Internal.VisualStudio.Shell.TelemetryHelper' threw an exception. The exception did not occur in VS 2015.

So I uninstalled the extension via Tools->Extension and Updates and retried the installation of 2.0.1 r7 for Visual Studio 2013 and it installed this time!!!

I'm confused. Now I'm running v2.0.1.7 in VS 2013 and v2.0.1.0 in VS 2015. It seems that Ray1984's for VS 2015 patch is based on an older version. I also assume that the VS 2015 installation fixed somehow the initial .Net-Framework issue.

What the heck... ;-)

Ray1984 wrote Sep 23, 2015 at 12:35 PM

Well....it seems that I did modify the package based on an older version :(

In fact, the .vsextension file of the original shows that the VSIX only works on the VS version it's compiled for.
If you want to install CSD for both VS2013 & VS2015, you have to install two vsixs, one for 2013, one for 2015.

So.....my patch should only works on VS2015. The reason why it can be installed on VS2013 is that I didn't delete the that configuration in .vsextension file :P
BTW...maybe I should download the HEAD version codes and recompile one :D